Intermittent "No Data" Status for Monitors

Incident Report for Datadog US5

Resolved

This incident has been resolved.
Posted Mar 18, 2026 - 22:53 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2026 - 22:39 EDT

Update

We are continuing to investigate the issue and will provide updates as available.
Posted Mar 18, 2026 - 22:04 EDT

Update

We are continuing to investigate the issue and will provide updates as available.
Posted Mar 18, 2026 - 21:27 EDT

Investigating

We are investigating an issue causing some metric monitors to intermittently report "No Data" status. This primarily affects monitors based on distribution metrics. Monitor alerting may be unreliable during this time. We are actively investigating and will provide updates as available.
Posted Mar 18, 2026 - 20:55 EDT
This incident affected: Monitors.