Delayed Distribution Metrics

Incident Report for Datadog US5

Resolved

This incident has been resolved.
Posted Aug 10, 2026 - 11:44 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 10, 2026 - 11:41 EDT

Investigating

We are investigating an issue with skipped evaluations of Distribution Metrics monitors.
As a result of this issue, some users may not receive alerts for monitors that use Distribution Metrics, but metrics shown in queries and dashboards are up to date.
Posted Aug 10, 2026 - 11:28 EDT
This incident affected: Metrics and Infra Monitoring.