We have seen recovery on live data of cloud resources across containers, processes views, database monitoring, network device monitoring, and fleet automation. Backfills of historical cloud resources will continue over the next few hours.
Posted Jun 26, 2026 - 00:33 EDT
Monitoring
The impact of this is incident is that under 5% of cloud resources show stale data. Cloud resources include containers, processes view, database monitoring, network device monitoring, fleet automation.
Updates for all resources are now being processed. We continue to work on the full backfill of data, which will take a few hours to finish.
Posted Jun 25, 2026 - 20:43 EDT
Update
The impact of this is incident is that under 5% of cloud resources show stale data. Cloud resources include containers, processes view, database monitoring, network device monitoring, fleet automation.
We are still working on a fix, but it is taking longer than expected. The full backfill of data will take multiple hours to finish, but we expect new updates to start being applied sooner than that.
Posted Jun 25, 2026 - 17:56 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 25, 2026 - 17:12 EDT
Update
We are continuing to work on a fix.
Posted Jun 25, 2026 - 16:02 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 25, 2026 - 14:58 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 25, 2026 - 14:02 EDT
Identified
We have identified the underlying issue and are working on a fix.
Posted Jun 25, 2026 - 12:36 EDT
Investigating
We are investigating increased lag processing data for cloud resources including containers, processes view, database monitoring, network device monitoring, fleet automation. As a result of this issue, some users may see stale data on those products.
Posted Jun 25, 2026 - 12:29 EDT
This incident affected: Cloud Cost Management, Cloud Network Monitoring, Cloud Security Management, and Database Monitoring.