Delayed distribution metrics processing

Incident Report for Datadog US5

Resolved

This incident has been resolved.
Posted Jul 13, 2026 - 10:34 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 13, 2026 - 09:19 EDT

Investigating

We are investigating increased latency processing distribution metrics.
As a result of this issue, some users may see delays or gaps for distribution metrics, monitors and SLO evaluation issues (when relying on distribution metrics) leading to alerting delays.

To prevent false monitor alerts due to delayed data, monitors affected by the delay will not notify and will automatically resume once current data is available. All other monitors will operate normally.
Posted Jul 13, 2026 - 08:34 EDT
This incident affected: Metrics and Infra Monitoring and Monitors.