Increased lag across multiple products

Incident Report for Datadog US5

Resolved

This incident has been resolved.
Posted Jun 05, 2026 - 11:57 EDT

Monitoring

We have deployed a fix and we are monitoring the results.
We will provide another update once the issue is fully resolved.
Posted Jun 05, 2026 - 11:47 EDT

Identified

We have identified the underlying issue and are working on a fix.
Posted Jun 05, 2026 - 11:11 EDT

Investigating

We are continuing to investigate increased lag processing data for cloud resources including containers, processes view, database monitoring, network device monitoring.
As a result of this issue, some users may see stale data on those products.
Posted Jun 05, 2026 - 10:38 EDT

Identified

We are investigating increased lag processing data for cloud resources including containers, processes view, database monitoring, network device monitoring.
As a result of this issue, some users may see stale data on those products.
Posted Jun 05, 2026 - 10:10 EDT
This incident affected: Cloud Cost Management, Cloud Network Monitoring, Cloud Security Management, and Database Monitoring.